Personal tools
You are here: Home Blog Control setuptools version installed by buildout bootstrap

Control setuptools version installed by buildout bootstrap

Filed under: , ,
use --setuptools-version as parameter when running bootstrap.py

A few weeks ago, I got mad for the xth times because my CI pipeline got broken again by zc.buildout bootstrap installing a version of setuptools that is incompatible with other parts of the pipeline.

With a few lines of code, I got a fix for this issue.

You can now find on github master branch a version of bootstrap.py that accepts the --setuptools-version parameter.

To control finely which versions of packages are actually installed at bootstrap time, you can now use something like : 

python bootstrap.py --setuptools-version=7.0 --version=2.2.5

This might be useful for those bitten by setuptools 8.0 and that cannot wait until all bugs are sorted out.

Enjoy,

Document Actions